Build issues

Robert Helling helling at
Sat Jan 4 11:00:37 PST 2020


> On 4. Jan 2020, at 17:37, Dirk Hohndel <dirk at> wrote:
> That answer makes no sense, Robert.
> The version that messed up your data is the version that wrote the very commit that removes the o2 value.
> So do a git log -p on your cloud repo and search for that specific change, and then look which version of Subsurface wrote that commit - it's in the commit message for that very reason.

Subsurface-mobile 2.2.3 (  was from git log. The problem is, I don’t know what I did that caused a write at all. I agree that this version will contain the bug (if it wasn’t me doing something stupid), but I will look into this to see if I can trigger it. I noticed this only as I looked into the repository for something unrelated.

> Then, ideally, revert that commit in a local copy of that cloud repo and start that same version of Subsurface locally and see if it does it again. And then all we need to do is bisect and figure out when this was introduced.
> If you want me to do that I can. Please give me permission to access your cloud storage data.

Feel free to if you want to. I reset those commits and force pushed that so it could well be that there is no trace of this. But I preserved it in a branch named „neu“ which I pushed to the cloud.

Regarding blowing away the build directory: I agree that this often helps, unfortunately not in this case. I even tried to blow away the whole ./src and start from scratch with a new clone but that reproduced the problem.

But as I said: Luckily, I can still get a working build, it’s just that every compile cycle takes an additional minute that gets annoying when doing it several times in a row.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 488 bytes
Desc: Message signed with OpenPGP
URL: <>

More information about the subsurface mailing list