Build issues

Dirk Hohndel dirk at
Sat Jan 4 11:07:00 PST 2020

> On Jan 4, 2020, at 11:00 AM, Robert Helling <helling at> wrote:
> Subsurface-mobile 2.2.3 (  was from git log. The problem is, I don’t know what I did that caused a write at all. I agree that this version will contain the bug (if it wasn’t me doing something stupid), but I will look into this to see if I can trigger it. I noticed this only as I looked into the repository for something unrelated.

Thanks for clarifying that.

>> Then, ideally, revert that commit in a local copy of that cloud repo and start that same version of Subsurface locally and see if it does it again. And then all we need to do is bisect and figure out when this was introduced.
>> If you want me to do that I can. Please give me permission to access your cloud storage data.
> Feel free to if you want to. I reset those commits and force pushed that so it could well be that there is no trace of this. But I preserved it in a branch named „neu“ which I pushed to the cloud.

Ok, I'll try to see if I can make sense of it.

> Regarding blowing away the build directory: I agree that this often helps, unfortunately not in this case. I even tried to blow away the whole ./src and start from scratch with a new clone but that reproduced the problem.
> But as I said: Luckily, I can still get a working build, it’s just that every compile cycle takes an additional minute that gets annoying when doing it several times in a row.

So for me this is an interesting dance. As long as I set the QT_QPA_PLATFORM_PLUGIN_PATH to the right directory, I can usually get away without running make install after every build - I only need it after the first build. So in my case that's


Can you try if that works for you?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list