<html><head><meta http-equiv="Content-Type" content="text/html charset=us-ascii"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div><blockquote type="cite" class=""><div class="">On Sep 18, 2016, at 12:44 PM, Dirk Hohndel <<a href="mailto:dirk@hohndel.org" class="">dirk@hohndel.org</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html charset=us-ascii" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class=""><br class=""><div class=""><blockquote type="cite" class=""><div class="">On Sep 18, 2016, at 10:01 AM, Robert Helling <<a href="mailto:helling@atdotde.de" class="">helling@atdotde.de</a>> wrote:</div><br class="Apple-interchange-newline"><div class=""><meta http-equiv="Content-Type" content="text/html charset=us-ascii" class=""><div style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" class="">Dirk,<div class=""><br class=""><div class=""><blockquote type="cite" class=""><div class="">Am 18.09.2016 um 18:24 schrieb Dirk Hohndel <<a href="mailto:dirk@hohndel.org" class="">dirk@hohndel.org</a>>:</div><br class="Apple-interchange-newline"><div class=""><span style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px; float: none; display: inline !important;" class="">OK, I have fixed a couple small problems on Windows and now things seem to</span><br style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class=""><span style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px; float: none; display: inline !important;" class="">compile everywhere. New daily builds for Windows, Mac, and Linux are on</span><br style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px;" class=""><span style="font-family: Helvetica; font-size: 12px; font-style: normal; font-variant-caps: normal; font-weight: normal; letter-spacing: normal; orphans: auto; text-align: start; text-indent: 0px; text-transform: none; white-space: normal; widows: auto; word-spacing: 0px; -webkit-text-stroke-width: 0px; float: none; display: inline !important;" class="">the server.</span></div></blockquote></div><br class=""></div><div class="">I cannot run the binary from the daily builds:</div><div class=""><br class=""></div><div class=""><div style="margin: 0px; line-height: normal;" class=""><span id="cid:6AF958E8-A647-468E-B06B-C8D7EA6B0F61@fritz.box" class=""><2LKtXVyDgfJnyAN1jK3c7_GlVKpjWgnFp5D180F3vRQ.png></span></div></div><div class=""><br class=""></div><div class=""><br class=""></div><div class="">and the report says:</div><div class=""><br class=""></div><div class=""><div class="">Crashed Thread:        0</div><div class=""><br class=""></div><div class="">Exception Type:        EXC_BREAKPOINT (SIGTRAP)</div><div class="">Exception Codes:       0x0000000000000002, 0x0000000000000000</div><div class="">Exception Note:        EXC_CORPSE_NOTIFY</div><div class=""><br class=""></div><div class="">Application Specific Information:</div><div class="">dyld: launch, loading dependent libraries</div><div class=""><br class=""></div><div class="">Dyld Error Message:</div><div class="">  Library not loaded: @executable_path/../Frameworks/libssh2.1.dylib</div><div class="">  Referenced from: /Volumes/VOLUME/Subsurface.app/Contents/MacOS/Subsurface</div><div class="">  Reason: Incompatible library version: Subsurface requires version 2.0.0 or later, but libssh2.1.dylib provides version 1.0.0</div></div></div></div></blockquote><br class=""></div><div class="">Fun - different versions of libssh2 are being used. Oops. I'll look into it.</div><div class=""><br class=""></div><div class="">I wonder why it didn't crash when I tried it here, though :-(</div></div></div></blockquote><div><br class=""></div></div>It did crash - I had tested the wrong DMG :-(<div class=""><br class=""></div><div class="">Anyway, fixed and replaced on the web server.</div><div class=""><br class=""></div><div class="">/D</div></body></html>