<div dir="ltr"><div><div>Good night.<br><br></div>Sorry for being so late to the thread.<br></div><div><div><div class="gmail_extra"><br><div class="gmail_quote">2017-01-05 14:30 GMT+01:00 Pedro Neves <span dir="ltr"><<a href="mailto:nevesdiver@gmail.com" target="_blank">nevesdiver@gmail.com</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi Willem:<span class=""><br>
<br>
On 05-01-2017 13:10, Willem Ferguson wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Pedro, that would be really great because I have not used that facility at all. The user manual has a section dealing with imports from protrietary divelogs, e.g. Mares, Suunto. I would suspect we would put the Scubapro information there as well.<br>
</blockquote></span>
Ok.</blockquote><div><br></div><div>Willem, I think I can write a full explanation of the tool tonight. I will mail it to you to format it and send a patch. <br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
<br>
The conversion software, is it Win-only? From the discussion at the time it looks like it actually runs on Linux as well.<br>
</blockquote>
<br></span>
No. I've used on my Arch linux machine. It's part of Subsurface's code. You can enable compilation and build by enabling it on CMakeLists.txt<br>
<br>
option(SMARTTRAK_IMPORT "enable building SmartTrak divelogs import tool (requires glib2 and libmdb)" OFF)<span class=""><br>
<br></span></blockquote><div><br></div><div>The tool is only tested on linux and as Pedro pointed out, it needs libglib2 and libmdb installed to build, this was the reason it didn't make as an import option of subsurface.  I thought I had mailed the list yesterday in another thread where you asked about smartrak import, but it seems the post never went off my laptop.<br> <br></div>The tool can't build ATM as it lacks two patches.  I have just put a P.R. on githut which  should fix the issue.<br><br></div><div class="gmail_quote">Regards.<br><br></div><div class="gmail_quote">Salva.<br></div><br></div></div></div></div>