Shearwater Petrel Download Bug

Patrick Valsecchi patrick at
Thu Jan 16 02:42:30 UTC 2014


I've investigated this issue on Linux some time ago and contacted the 
bluez mailing list about that. They totally ignored me but a week later, 
another guy had the same problem and did a better investigation than me. 
His conclusion was that if we open /dev/rfcomm0 in asynchronous mode and 
then write to it, we are screwing bluez and the first write fails 
because it happens before the rfcomm link is completely setup.

I've tried to modify the libdivecomputer to open in synchronous mode and 
then set the fd to asynchrounous afterwards, but the dive transfer was 
still failing on the first read operation. I've sniffed the USB 
communication and looks like something is sending seemingly random 
characters  before and after the command we send.

Since I had the impression that I was the only one with this problem in 
the subsurface community and the bluez community was ignoring me, I've 
quit after 8h of investigations.


On 14. 01. 14 17:30, Rodrigo Severo wrote:
> On Tue, Jan 14, 2014 at 12:09 PM, Dirk Hohndel <dirk at 
> <mailto:dirk at>> wrote:
>     Update - I tried again under MacOS and can report that the
>     download from
>     my Petrel actually works with 4.0.2 (not sure what went wrong a couple
>     of days ago).
>     /D
>     On Tue, 2014-01-14 at 18:27 +0700, Dirk Hohndel wrote:
>     > Yeah - that one basically just says that Subsurface tried to say
>     "Hi" to
>     > the dive computer and the dive computer ignored us.
>     >
>     > With the Petrel I always worry about making sure the right device is
>     > used. I am having problem with my own Petrel downloading under MacOS
>     > right now, so I'm in the same boat to some extend...
> On my kubuntu 13.10 laptop instead of using
> sudo rfcomm bind /dev/rfcomm0 10:00:E8:C4:BE:C4
> as instructed by Subsurface's manual I have to use
> sudo rfcomm connect /dev/rfcomm0 10:00:E8:C4:BE:C4
> and them all works fine.
> Rodrigo
> _______________________________________________
> subsurface mailing list
> subsurface at

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list