Hollis DG03 data import error

Jef Driesen jefdriesen at telenet.be
Wed May 21 23:58:51 PDT 2014

On 2014-05-22 08:12, Gobbledegeek wrote:
> This issue is still pending resolution. I left on a dive vacation and
> forgot about sync'ing my DC after that. So far I've just been using my 
> DC
> for dives without logging.
> Now I am trying again on a fresh install of Ubuntu 14.0.4LTE.
> Here are the things I tried:
> $ ls -l /dev/ttyU*
> crw-rw---- 1 root dialout 188, 0 May 22 11:24 /dev/ttyUSB0
> $ sudo chmod 0666 /dev/ttyUSB0
> $ ls -l /dev/ttyU*
> crw-rw-rw- 1 root dialout 188, 0 May 22 11:25 /dev/ttyUSB0
> I tried making the above permanent on reboot with a
> /etc/udev/rules.d/50-usbtty-rules file that read:
> KERNEL=="ttyUSB*", MODE="0666"
> but this resulted in my usb mouse and keyboard becoming unresponsive on
> reboot, so I removed it.
> Then I tried the instructions by Jef given earlier when this thread was
> active:
> it seems modem-manager thinks you just connected a modem and takes the
> device. you could create an udev rule to blacklist some usb serial
> devices. look at (something like, probably /usr/lib)
> /lib/udev/rules.d/77-mm-usb-de
> vice-blacklist.rules
> then create a similar file in /etc/udev/rules.d containing the pid/vid
> of your divecomputer
> <<<
> $ lsusb
> Bus 001 Device 014: ID 0403:f460 Future Technology Devices 
> International,
> Ltd
> with  /etc/udev/rules.d$ cat 50-divecomputer-blacklist.rules
> ATTRS{idVendor}=="0403", ATTRS{idProduct}=="f460",
> and
> $ sudo stop modemmanager
> No luck.
> So to summarize:
> 1. Adding my user to dialout group did not work
> 2. stopping  modemmanager did not work
> 3. Adding a blacklist rule for my device did not work.
> Any other ideas to fix this? I tested with windows using the hollis
> software and it works.

You are referring to solutions for the access permissions on the 
/dev/ttyUSB0 device node, but at the same time you attach a logfile that 
indicates you are able to open the device successfully. So that means 
whatever you did to the /dev/ttyUSB0, it already worked!

To fix the high number of timeouts and NAK's during the communication, 
you'll need something completely different. The libdivecomputer master 
branch (v0.5.0-devel) already contains a fix for this issue. I don't see 
any evidence of this fix in your log, so I assume you are using an older 
version. Upgrade and downloading should work again.


More information about the subsurface mailing list