Stuck making Subsurface on Mac

Steve Ratts steveratts at
Fri May 23 23:15:32 PDT 2014

Oh, well a buddy of mine and I both have the Uemis Zurich SDA and we've
both had a devil of a time getting it to download lately. My buddy's
experience is a little different than mine, but ultimately it's still

At first, I had no trouble downloading dives and thought it worked
perfectly. In fact I persuaded my buddy to give Subsurface a try primarily
on this one major capability (I don't know anyone who likes the Uemis
web-based dive log, but then I only know three people using the SDA and
that includes you, Dirk.)

When my buddy tried out downloading in Subsurface he immediately ran into a
problem and was unable to get any dives downloaded. The SDA would appear to
connect, but no dives would download, and he'd get the dreaded out of
memory error which has been described in the Subsurface manual. This past
February he and I went to Bonaire with some friends and we both worked on
the issue together. At that time I had about 100 dives logged in the SDA
and he had closer to 200. I had been downloading them steadily as I went,
so never needed to download more than a dozen or so. One theory we had was
that since he had so many more dives logged in his SDA than I did, that
might be the cause of the problem. However at the time I was using
Subsurface 3.0.2 and he was using 4.0. I tried upgrading to 4.0 to see if
that was the source of the problem and immediately I lost the ability to
download dives. FWI, he and I were both using Windows based laptops for
this. I tried rolling back to 3.0.2, but it was no use, I had lost the
capability to download. We tried just about everything we could think of,
but had no luck. Eventually I was able to regain the capability, but only
after I got home, download my SDA using 3.0.2 on my hackintosh, and then
ported the dive log over to the Windows laptop. Incidentally, he was
eventually able to get his log into Subsurface too, but it was extremely
difficult. I'd have to go back and review email to see what finally did the
trick for him.

One thing I would really really like is a capability to output a diagnostic
log during the SDA download step so that at least I could see how far it
got and where i hangs. Subsurface claims to be able to do this, but AFAIK
this capability does not actually work. Also, I've noticed that if there is
one good thing about the Uemis web-based divelog it's that it can download
essentially any number of dives without choaking and hitting this out of
memory error (SDA file system full) that Subsurface often hits. I would
like to look into that to see if it's possible to improve the Subsurface
download process. Those Uemis guys, as insane as they may be, are doing
something right if they can reliably get the SDA to download any number of
dives without choking.

I'm sorry, but looking at what I've wrote, I don't think it offers much
concrete to describe the problem. It's late here, but I'll go back into my
email to see if I can find something more specific about what was going

In any event, it's great to know there are allies out there with SDA's, and
that you and Linus are among them. The SDA is a great computer!


On Fri, May 23, 2014 at 8:22 PM, Dirk Hohndel <dirk at> wrote:

> On May 23, 2014, at 7:32 PM, Steve Ratts <steveratts at> wrote:
> Thanks Dirk,
> I uninstalled qt (to get rid of dbus), and then installed it again, and
> reran the make on marble (getting the 'Qt QTDBUS library not found'
> messages)
> brew uninstall qt
> brew install qt
> cd ~/src/marble/build
> -DCMAKE_INSTALL_PREFIX=/usr/local ../sources
> cd src/lib/marble
> make -j4
> install_name_tool -id /usr/local/lib/`echo libmarblewidget.??.dylib`
> libmarblewidget.dylib
> cp *dylib /usr/local/lib/
> mkdir -p /usr/local/include/marble
> cd ../../../../sources/src/lib
> cp $(find . -name '*.h') /usr/local/include/marble/
> The version of libgit2 I have is apparently v0.20.0. When I previously
> executed the brew install libgit2 I got the following response.
> ==> Downloading
> ########################################################################
> 100.0%
> ==> cmake .. -DBUILD_TESTS=NO
> -DCMAKE_INSTALL_PREFIX=/usr/local/Cellar/libgit2/0
> ==> make install
> 🍺  /usr/local/Cellar/libgit2/0.20.0: 69 files, 1.2M, built in 19 seconds
> Going back through my install log, I see that the version of AsciiDoc brew
> installed was 8.6.9.mavericks, and that brew advised I should add 'export
> XML_CATALOG_FILES=/usr/local/etc/xml/catalog' to my .bashrc file, which I
> did, and of course I also sourced that file to refresh things. However I
> now get the following error when attempting to make the documentation from
> within the Documentation folder
> a2x -f pdf user-manual.txt
> a2x: ERROR: "dblatex" -t pdf -p
> "/usr/local/Cellar/asciidoc/8.6.9/etc/asciidoc/dblatex/asciidoc-dblatex.xsl"
> -s
> "/usr/local/Cellar/asciidoc/8.6.9/etc/asciidoc/dblatex/asciidoc-dblatex.sty"
>   "/Users/Steve/src/subsurface/Documentation/user-manual.xml" returned
> non-zero exit status 127
> make: *** [user-manual.pdf] Error 1
> I’m sorry, I should have mentioned that it might fail - but that doesn’t
> matter, it still fixes the issue.
> Given this result, I opted for Robert's suggestion to cp
> Documentation/user-manual.html.git Documentation/user-manual.html
> This appears to get me unstuck and I've now been able to do a make for
> subsurface.
> You were already unstuck, you just didn’t realize it :-)
> Good news! The app runs, loads my divelog, and now reports itself as
> Subsurface 4.1.74
> Cool
> Next step is to see what can be done about adding filtering to columns,
> and possibly work on improving the Uemis download (which is, quite frankly,
> flaky)
> Tell me more what’s flaky - I think I’m familiar with all of its warts… I
> wrote this (reverse engineering their web based uploader) and use it quite
> frequently.
> Reading that code will make your eyes bleed. The downloading protocol is
> so incredibly stupid that there aren’t enough words in the English language
> to describe the degree of drug induced insanity that the people who
> designed it clearly were affected by.
> But I really want to know if you are running into problems I haven’t seen
> - and I would love to have another active tester. So far it’s only Linus
> and me amongst the active developers.
> /D
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the subsurface mailing list