AP Vision import

Lubomir I. Ivanov neolit123 at gmail.com
Fri Apr 14 14:12:06 PDT 2017


On 15 April 2017 at 00:01, John Smith <noseygit at hotmail.com> wrote:
> To import data from my AP CCR, I have to download from the unit onto AP
> software, export as csv and then import to Subsurface as a log file.
> It worked well for some time however recently I've been getting parsing
> errors on import.
> I ran subsurface -v and in the CMD window it identified the problem as non
> UTF-8 characters in the file.
> It turns out that in the ap export there is a degrees symbol that upsets
> subsurface. Its easy enough to fix using a txt editor,  but is there a way
> that the import be changed to ignore the first line if necessary?

might be a good idea to post the file so that the mailing list can examine it.

> Secondly, when changing the time of a dive, if you use the up/down arrows to
> make small changes, they only work in units of 2, ie it goes from 11 to 13.
> Thats the same for both hours and minutes.

if you use the up/down arrows in the keyboard it works for me.
but that's true, clicking the up/down buttons goes in steps of two.
my whole UI freezes while doing that, so my suspicion is that the
changing the time does too much calculation, locks the UI thread and
the user mouse-down action last longer - i.e two steps.


More information about the subsurface mailing list