new releases

Dirk Hohndel dirk at
Fri Jun 15 22:41:14 PDT 2018

> On Jun 16, 2018, at 2:01 PM, Jan Iversen <jani at> wrote:
>> So far I found one odd bug in Subsurface-mobile with downloading from the Suunto EON Steel. Even though I had new dives on the DC, Subsurface-mobile told me there were no new dives. I added debug output and tried again, and of course it worked correctly :-/
> This also happens on the mobile version (master and test flight), with Suunto EON Core. I have seen it a couple of times. Connection with BLE is made correctly, firmware version etc. written on screen and then no dives found. If you try again without restarting ssrf it  works. I thought it was something like a ble tineout. There are no indications in the normal logs.

Linus is looking into that one

>> The other issue I see on Mac is that some of the dialogs have partially cut off texts. I'm currently trying to figure out how to even debug this. There's no reason I can figure out why those should not automatically size correctly...
> I can confirm that. It hits the divedetails window among others. I have not searched for it, but I saw about a month ago.

I think I have fixed this. Waiting for comments from Robert

>> What other bugs do we know of for either desktop or mobile?
> mobile: the ssrf logo in the coral picture, still shows as a black spot.

Right. I noticed that as well.


More information about the subsurface mailing list