How to build iOS simulator and iOS device ?

Jan Iversen jani at
Fri May 4 01:25:26 PDT 2018

Sent from my iPad

> On 4 May 2018, at 10:06, Dirk Hohndel <dirk at> wrote:
>> On May 4, 2018 9:08:14 AM GMT+02:00, Miika Turkia <miika.turkia at> wrote:
>>> On Fri, May 4, 2018 at 10:02 AM, <jani at> wrote:
>>>> but I'm not sure I want to be stuck with maintaining this as part
>> of our
>>>> source repository". If you can make this work, make this EASY TO
>>> consider
>>>> it - but please understand that I might also look at it and say
>> "yeah,
>>>> no”.
>>> Fair arguments, but a bit unfair against the newer versions of Xcode.
> I am using 9.3
> I think every version I try is worse than the one before.
>>> My aim is to have a simple IDE, where I can develop/generate and
>> test. How
>>> do the Linux developers, hope not like I do sometimes use vi :-)
> I use QtCreator and am very happy with it for rapid edit/compile/debug integration.
>> I have to admit I have moved on from vi and use vim nowadays. Just a
>> lot
>> more comfortable to use than any IDE I have tried.
> Ah, yes. And then we have a few developers who are truly hard core. At least one is using ue as his IDE :-)
> But let me repeat... I'm willing to consider it, and if this is a trade-off that gets us another active developer for iOS, I'll try to be flexible... but I will also need to value maintainability quite highly.

That is very clear to me, I am playing with a combination of vi, make and simulator. I want to help the project not be a burden :-)

Anybody knows how to get QtCreator to start the ios simulator ? 

I called subsurface/scripts/ -build-deps -both
then tried to drag subsurface/build-mobile/ into the simulator, but I get a very informative message “cannot be installed right now, try later” any hints ?

Ps. will forget Xcode for now, and see if I can debug effectively with QtCreator (or Xcode without generating a project).

jan i
> /D

More information about the subsurface mailing list